Problema su Bridge

Roberto Canella anatolle a tiscali.it
Mer 16 Feb 2005 22:14:07 CET


Dario Freni wrote:
> Roberto Canella (anatolle a tiscali.it) wrote:
> 
>>Vi descrivo brevente il mio problema,
>>
>>1) ricompilato il Kernel per includere bridge e ipfw
>>
>>2) configurato il bridge in modalita? ipless
>>
>>3) collegato il bridge fra due computer aventi uno indirizzo
>>   ip 192.168.0.1 e l?altro 192.168.0.2
>>
>>4) configurato ipfw con le seguenti regole:
>>     ipfw add allow udp from 0.0.0.0 2054 to 0.0.0.0
>>     ipfw add allow icmp from any to any
>>     ipfw add deny log logamount 10 ip from any to any
>>
>>Il problema e? che un banalissimo ping dalla macchina 192.168.0.2 non
>>raggiunge 192.168.0.1 dando sul file di log il seguente messaggio:
>>Feb 15 21:47:45 morgana kernel: ipfw: 300 Deny MAC in via rl0
>>Feb 15 21:47:54 morgana last message repeated 9 times
>>Feb 15 21:47:54 morgana kernel: ipfw: limit 10 reached on entry 30
>>
>>Se disabilito ipfw riesco a pingare, se configuro ipfw per
>>"far passare tutto" riesco a pingare. Ma la cosa piu? strana e? che se
>>una volta che sono riuscito a pingare (con uno dei due metodi
>>precedenti) riabilito le regole di ipfw... funziona tutto.
>>
>>Secondo me il problema e? "hardware" visto che le due schede di rete sul
>>bridge sono delle banalissime realtek secondo voi ?
>>
>>Potete darmi una mano ?
> 
> 
>   Probabilmente hai abilitato il firewall a livello bridge e/o a livello
> ethernet. Che procedura hai seguito per il bridge?
> 
> 
Il firewall e' abilitato intenzionalmente, ma pensavo che con le regole
che ho inserito in ipfw i pacchetti ICMP passassero... sinceramente non
riesco a capire dove sbaglio :-(

Ciao Roberto



Maggiori informazioni sulla lista aiuto