Scheda audio integrata

Valerio Alliod va.ml a ieio.vda.it
Lun 24 Ott 2005 15:34:19 CEST


em.conti a tin.it ha scritto:
> Salve a tutti, 
> rompo ancora perché proprio non riesco a configurare la scheda audio
> integrata. Avevo postato per lo stesso problema qualche tempo fa e mi fu
> risposto di fare un upgrade alla FreeBSD 4.11. Sebbene dubitassi che
> fosso un problema di kernel (ma piuttosto di modulo), ho effettuato
> l'aggiornamento (dalla 4.9). Il problema però permane.

Diciamo che aggiornando il kernel (che poi significa aggiornare i
sorgenti per poter compilare un kernel nuovo), vengono aggiornati anche
i moduli. Poi sarà una tua scelta avere il kernel più scarico e caricare
i moduli per le periferiche che li supportano, oppure integrare tutto
nel kernel. Ed inoltre reputo incosciente e pericoloso aggiornare
solamente i moduli mantenendo un kernel vecchio.

> Dal manuale alle varie mailing lists tutti dicono che il problema si
> risolve ricompilando il kernel inserendo la voce "device pcm".
> Nienta da fare, la NVIDIA proprio non ne vuole sapere di farsi vedere.
> Ma la cosa più assurda è che tutti gli altri dispositivi integrati
> vengono rilevati (USB 2.0, scheda grafica persino la ethernet
> integrata).

Beh, non mi pare assurda come situazione... se per le altre periferiche
sono presenti i driver allora funzionano, altrimenti no... ed
evidentemente nel ramo 4.x hanno inserito i driver per tutto il resto
tranne che per la scheda sonora.

> Dando un dmesg credo di aver individuato la scheda sonora
> 
> pci0: <unknown card> (vendor=0x10de, dev=0x00ea) at 6.0 irq 9
> 
> che è l'unica con <unknown card> (ma anche l'irq è sospetto).

Uhm, e cosa ti insospettisce di un simpaticissimo irq 9?
In ogni caso, nel "device pcm" non è presente il supporto per la tua
scheda sonora integrata nel chipset nForce3... il driver è presente
invece nella 5.x "device snd_ich".

> Ma proprio non riesco a fargliela riconoscere.
> Se qualcuno ha qualche idea . . .

Hai una motherboard con chipset nForce3 quindi probabilmente amd64,
quindi piattaforma nuova... aggiornare alla 5.4?
Se non ti è indispensabile rimanere nel ramo 4.x suppongo sia l'unico
sistema per vederti riconosciute la maggior parte delle periferiche
molto recenti.

> Ciao
> emilio

Bye bye

Valerio


Maggiori informazioni sulla lista aiuto