Chi ci capisce e' bravo

Valerio Alliod va.ml a ieio.vda.it
Mar 25 Ott 2005 20:57:27 CEST


em.conti a tin.it ha scritto:
> Questo lo so. Infatti per le 4.x si deve mettere
> device         pcm  (al posto di sound)
> 
> però se poi aggiungo 'device snd_ich' (che dovrebbe essere quello
> corretto anche per me) il config mi da un avvertimento. Se proseguo con
> il make depend questo si blocca per cui non posso utilizzare la doppia
> entry, ma solo "device   pcm" (che però, come dicevo, bob funziona).
> 
> Adesso è tardi e ho avuto un pomeriggio folle dal dentista.
> L'output di dmesg e il file di configurazione del kernel lo posto
> domattina.
> 
> 
> Ciao
> emilio

Ehm, per l'ennesima volta e senza offesa:
nel ramo 4.x _NON_ c'è il supporto per la tua scheda sonora.
E' sufficiente fare una ricerca per vendor=0x10de e dev=0x00ea
all'interno dei sorgenti per sincerarsi del fatto che non viene
riconosciuta dal driver device pcm.
Il device sound + device snd_ich (che sarebbero quelli giusti per la tua
scheda) funzionano _SOLO_ dalla 5.x in avanti (come detto da me in
precedenza e ripetuto da Gianmarco).

Quindi:
- o aggiorni a > 5.x
- o ti modifichi i sorgenti inserendo vendor e dev così che venga
riconosciuta e speri che poi funzioni
- o aspetti che qualcuno porti il driver nella 4.x
- oppure il porting lo fai tu.
Non vedo alternative... (opinione personalissima: con il PC che ti
ritrovi, un amd64 suppongo, direi che se aggiorni hai migliori
possibilità per sfruttare meglio l'hardware che ti ritrovi).

Ciao

Valerio


Maggiori informazioni sulla lista aiuto