PHP4 help please

marcop marco a leduke.biz
Ven 11 Maggio 2007 16:23:01 CEST


Ciao a tutti. 

Ho da tempo installato su un FreeBSD 5.5 il PHP4-4.4.5 con le relative 
estensioni 1.0. 

Da qualche giorno portaudit mi ha avvisato problemi di sicurezza relativo al 
port suddetto, di solito attendo qualche giorno prima di eseguire il 
classico:make deinstall --> make install clean 

Ebbene, oggi ho aggiornato i ports, mi sono apprestato a rimuovere il 
PHP4-4.4.5 e relative estensioni e non appena ho avviato il make da:
/usr/ports/lang/php4 ricevo: 

/usr/ports/lang/php4# make install 

************************************************
===>  php4-4.4.6 has known vulnerabilities:
=> php -- multiple vulnerabilities.
  Reference: 
<http://www.FreeBSD.org/ports/portaudit/f5e52bf5-fc77-11db-8163-000e0c2e438a 
.html>
=> Please update your ports tree and try again.
*** Error code 1 

Stop in /usr/ports/lang/php4.
*** Error code 1 

Stop in /usr/ports/lang/php4.
************************************************
Ho letto ovviamente il link segnalato...
Perņ fino ad adesso i ports su freebsd.org non sono aggiornati, sono rimasti 
alla 4-4.4.6... 

Preferirei installare PHP4 SOLO ed ESCLUSIVAMENTE dai PORTS...
Siccome ho un archivio web "fermo" non saprei quando e se i ports saranno 
aggiornati su freebsd.org. 

Tra l'altro, vedo che su www.php.net il 4-4.4.7 č stato rilasciato il 3 
maggio e ad oggi nessun aggiornamento su freebsd.org.
Prima di essere linciato dagli utenti, cosa posso fare?
Chiedo il vostro aiuto, grazie. 




Maggiori informazioni sulla lista aiuto