PHP4 help please

Mark marco a leduke.biz
Dom 13 Maggio 2007 08:29:00 CEST


Grazie a tutti per gli aiuti proposti.
Ho dovuto installare il port forzandolo:

/usr/ports/lang/php4/make install -i
E poi #make clean

In questo modo viene installato ignorando le security check e senza dovere
disinstallare portaudit.

Cristiano Deana wrote:
> # make -DDISABLE_VULNERABILITIES reinstall

Il reinstall invece mi chiede di DISINSTALLARE e poi INSTALLARE

Riccardo Torrini wrote:
> Nonostante il knob possa far pensare diversamente questo non
> risolve i problemi di vulnerabilita` ma ignora semplicemente
> il controllo effettuato da portaudit

Infatti, io speravo ad una soluzione (dai port) che potesse ottemperare alle
segnalazioni di vulnerabilità.
Purtroppo adesso mantengo la 4-4.4.6 e non se ne parla della versione 5
perché mi sembra esagerato per una sola pagina in PHP.

Il problema è che ultimamente, pur avendo restrizionato gli IP pubblici con
ipfw2, continuo a ricevere attacchi dall' Iran, Korea e China, ed un PHP
vulnerabile non mi rende tranquillo.....

Potrebbe essere risolutivo scaricare il tar ed eseguire l'install a manina
NON dai ports (non lo sopporto).

Grazie e buona Domenica a tutti!

p.s. Oggi fate gli auguri alle vostre Mamme!!!!



Maggiori informazioni sulla lista aiuto