ISO-STABLE

Riccardo Torrini riccardo a torrini.org
Mer 7 Gen 2009 21:53:42 CET


On Wed, Jan 07, 2009 at 04:06:48PM +0100, xer wrote:

> Ho dei problemi con una copia della 6.4-STABLE eseguita
> in cpdup su hard disk.
> L'obiettivo e` di sostituire l'hardware utilizzando poi
> la copia eseguita con cpdup.
> In pratica dopo averla copiata su un nuovo disco, non ha
> nessuna voglia di fare il boot sulla nuova macchina.
> Dopo il boot FreeBSD F1
> Mi appaiono una serie di numeri in cascata... 
> Di certo, hardware diverso, bios diverso, presumo sia
> relativo all'MBR ed al controller del disco.
> Stiamo parlando di un disco IDE.

E` una procedura che ho fatto piu` e piu` volte, anche passando
da disco ide a sata-II e anche passando dal k6/350 al sempron.
Addiruttura in ditta ho migrato un x335 (dischi scsi ultra/320
in mirror) dal disco da 72 a quello da 144 smontanto il mirror,
mettendo il secondo disco, facendo la copia e ripartendo con
il disco piu` grosso e infine riattivando il mirror hardware.

Tutto questo su macchine sveglie (in produzione) tranne che
dopo il primo cpdup facevo un boot in single user e rifacevo
il cpdup per non perdere nemmeno una riga di log (e tenendo
la macchina spenta per il minimo indispensabile).

Una domanda: hai partizionato e provato a fare il boot con il
nuovo disco _prima_ di iniziare con la copia vero?  Se usi
sysinstall invece di crearti ad{n}a sul secondo disco ti fa una
ad{n}d a meno che tu non gli dia un mount point / e poi lo cambi
in /mnt/r (per esempio).

La cosa piu` sicura in assoluto e` partire con cd di freebsd
sulla macchina nuova, partizionare il disco e fare una mini
installazione, smontare il disco e metterlo come secondo alla
macchina da clonare e fare la copia partizione per partizione,
tanto il cpdup cancella tutto quello che non serve...

PS: se non devi fare multi-boot non installare il bootmanager.


-- 
Riccardo. ( http://www.GUFI.org/~vic/ )


Maggiori informazioni sulla lista Aiuto