glusterfs

Enrico M. enricom a teppisti.it
Lun 6 Lug 2009 15:02:06 CEST


On Monday 06 July 2009 13:11:23 Guido Falsi wrote:
> On Mon, Jul 06, 2009 at 11:51:20AM +0200, Enrico M. wrote:
> > On Sunday 05 July 2009 19:28:53 Enrico M. wrote:
> > > Qualcuno di voi ha installato glusterfs?
> > > Io ho provato con 2.0.2 ma non riesco a compilare
> > > Grazie
> >
> > Risolto!
> > Bisognava impostare alcune variabili d'ambiente:
> > setenv LDFLAGS "-L/usr/local/lib -liconv"
> > setenv CFLAGS "-O0 -g -DDEBUG -I/usr/local/include/"
> >
> > Ho visto però che nononostante abbia esplicitamente dato il configure con
> > alcune opzioni
> > (./configure --enable-fuse-client --enable-libglusterfsclient), la
> > libglusterfsclient e quindi il supporto a booster non vengono abilitati:
> >
> > GlusterFS configure summary
> > ===========================
> > FUSE client        : yes
> > Infiniband verbs   : no
> > epoll IO multiplex : no
> > Berkeley-DB        : no
> > libglusterfsclient : no
> > mod_glusterfs      : no ()
> > argp-standalone    : yes
> >
> > Appena avrò un pò di tempo continuerò con le prove, così da vedere se
> > funziona Qualsiasi consiglio o suggerimento è ben accetto
>
> Io ho imparato che raramente conviene compilare a mano, anche quando non
> siste un port conviene crearne uno al volo.
>
> L'infrastruttura dei port imposta gia' automaticamente una serie di
> variabili di ambiene e variabili make/gmake che risolvono vari
> problameucci che altrimenti tocca risolvere a mano...e non e' neanche
> difficile creare un port da zero, certo richiede un po' piu' di rigore
> che patoccare dalla shell.
>
> Ha anche il simpatico effetto collaterale che alla fine uno ha gia' un
> port pronto e che puo' mandare oper inserirlo nell'albero ufficiale.

Intanto, impazientemente, sono andato avanti
l'ho installato su due macchine, entrambi facenti da server e una delle due 
anche da client.
Ho creato i files vol ed ho avviato. Dal logfile tutto regolare
Monto e tutto ok
Quando vado a leggere o scrivere nel filesystem replicato, però, mi 
disconnette:
.............
[2009-07-06 14:54:30] N [server-protocol.c:7035:mop_setvolume] server: 
accepted client from 192.168.1.2:1023
[2009-07-06 14:54:30] N [server-protocol.c:7035:mop_setvolume] server: 
accepted client from 192.168.1.2:1022
[2009-07-06 14:55:02] N [server-protocol.c:7796:notify] server: 
192.168.1.2:1023 disconnected
[2009-07-06 14:55:02] N [server-protocol.c:7796:notify] server: 
192.168.1.2:1022 disconnected
[2009-07-06 14:55:02] N [server-helpers.c:723:server_connection_destroy] 
server: destroyed connection of 
hal.homeunix.net-61770-2009/07/06-14:54:39:718380-remote1
...................

[2009-07-06 14:54:39] N [server-protocol.c:7035:mop_setvolume] server: 
accepted client from 192.168.1.2:1021
[2009-07-06 14:54:39] N [server-protocol.c:7035:mop_setvolume] server: 
accepted client from 192.168.1.2:1020
[2009-07-06 14:55:11] N [server-protocol.c:7796:notify] server: 
192.168.1.2:1021 disconnected
[2009-07-06 14:55:11] N [server-protocol.c:7796:notify] server: 
192.168.1.2:1020 disconnected
[2009-07-06 14:55:11] N [server-helpers.c:723:server_connection_destroy] 
server: destroyed connection of 
hal.homeunix.net-61770-2009/07/06-14:54:39:718380-remote2


Maggiori informazioni sulla lista Aiuto