virtualbox OSE (Enrico M.)

Enrico M. enricom a teppisti.it
Mar 10 Nov 2009 22:50:56 CET


On Monday 09 November 2009 21:40:45 Enrico M. wrote:
> Allora, rifacciamo il punto.
> Se imposto l'interfaccia di rete della macchina virtuale con il NAT, funge
> senza problemi.
> Se, invece, voglio fare bridge con l'interfaccia della macchina host, non
> mi funziona.
> Come si fa ad usare il bridge?
> Da ifconfig vedo che ho una nuova interfaccia di rete:
> vboxnet0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
>         ether 0a:00:27:00:00:00
> Grazie
> Enrico

Risolto!
Ad un certo punto mi ero pure posto il problema di dover creare il bridge a 
manella, ma poi leggendo la doc ho visto che nelle ultime versioni di 
virtualbox questo non è necessario
Sono riandato su http://wiki.freebsd.org/VirtualBox e mi sono soffermato su 
questa riga:
load the modules vboxnetflt and vboxnetadp (in that order) 
Io avevo inserito due righe in /boot/loader.conf
....
vboxdrv_load="YES"
vboxnetflt_load="YES"
vboxnetadp_load="YES"
..............
affinché svolgesse il compito automaticamente, presupponendo che i moduli 
venissero caricati secondo l'ordine in cui erano indicati nel file.
Ma ciò non è vero
Caricati i moduli a manella a sistema già avviato funziona anche in modalità 
bridge
Cosa assai strana, dando kldload, ho visto che caricando i moduli a mano 
secondo quell'ordine ne viene caricato anche un altro, ng_ether.ko, che con 
le mie precedenti impostazioni in /boot/loader.conf non veniva caricato.
Questa cosa proprio non riesco a spiegarmela
Comunque, modificando /boot/loader.conf in questo modo
...............
vboxdrv_load="YES"
vboxnetflt_load="YES"
netgraph_load="YES"
ng_ether_load="YES"
vboxnetadp_load="YES"
...................
funziona anche in modalità bridge senza caricare i moduli a mano
Spero possa tornare utile a qualcuno
Enrico


Maggiori informazioni sulla lista Aiuto