FBSD9 e ZFS

Franco Marchesini franco.marchesini a gmail.com
Mar 28 Feb 2012 14:48:35 CET


Il 28 febbraio 2012 14:45, Davide D'Amico <davide.damico a gmail.com> ha scritto:
> Il 28 febbraio 2012 14:34, Franco Marchesini
> <franco.marchesini a gmail.com> ha scritto:
>> Il 28 febbraio 2012 14:14, Davide D'Amico <davide.damico a gmail.com> ha scritto:
>>> Il 28 febbraio 2012 13:03, Franco Marchesini
>>> <franco.marchesini a gmail.com> ha scritto:
>>>> Il 28 febbraio 2012 12:40, Davide D'Amico <davide.damico a gmail.com> ha scritto:
>>>>> Il 28 febbraio 2012 11:09, Franco Marchesini
>>>>> <franco.marchesini a gmail.com> ha scritto:
>>>>>> Ciao a tutti,
>>>>>> ho deciso di cimentarmi con lo zfs seguendo questa guida
>>>>>>
>>>>>> http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/9.0-RELEASE
>>>>>>
>>>>>> L'unica differenza, rispetto alla guida, che la macchina di prova non
>>>>>> ha dischi in mirror, per cui, al comando:
>>>>>>
>>>>>> # zpool create -o altroot=/mnt zroot mirror /dev/gpt/disk0 /dev/gpt/disk1
>>>>>>
>>>>>> io ho sostituito il comando
>>>>>>
>>>>>> # zpool create -o altroot=/mnt zroot  /dev/gpt/disk0
>>>>>>
>>>>>> ma non funziona perche' mi risponde con:
>>>>>>
>>>>>> invalid vdev specification
>>>>>> use '-f' to override the following errors:
>>>>>> /dev/gpt/disk0' is part of potentially active pool 'zroot'
>>>>>>
>>>>>> ed al comando successivo:
>>>>>> # zfs create zroot/tmp
>>>>>>
>>>>>> mi dice che non c'e' il pool zroot
>>>>>>
>>>>>> cannot create 'root/tmp': no such pool 'root'
>>>>>>
>>>>>>
>>>>>> Qualche idea?
>>>>> Potresti iniziare da un zpool status :)
>>>>
>>>> #zpool status
>>>> no pool available
>>>
>>> La procedura mi sembra corretta, compreso il fatto che il pool č 'vuoto'.
>>>
>>> # gpart show
>>> # gpart show -l
>>>
>>> che dicono?
>>
>> Tralascio la parte relativa alla chiavetta
>>
>> #gpart show
>>
>>      34      976773101     ada0   GPT   (465G)
>>      34            128        1   freebsd-boot  (64k)
>>     162       16777216        2   freebsd-swap  (8.0G)
>> 16777378      959995757        3   freebsd-zfs   (457G)
>>
>>
>> # gpart show -l
>>
>>      34      976773101     ada0   GPT     (465G)
>>      34            128        1   (null)   (64k)
>>     162       16777216        2   swap0   (8.0G)
>> 16777378      959995757        3   disk0   (457G)
>
> Mi sembra corretto: appena posso, provo su una VM e ti faccio sapere.

ok, intanto grazie per il supporto.

Se puņ' essere utile (ma non penso) il disco non era vergine, c'era
una installazione di freebsd.
Ho dovuto fare prima il:

gpart delete -i ...

delle partizioni e poi il

gpart destroy ada0

Ciao
Franco


Maggiori informazioni sulla lista Aiuto