problema connessioni smtp dietro bridge

Matteo Sgalaberni sgala a sgala.com
Ven 22 Apr 2005 19:37:22 CEST


On Fri, Apr 22, 2005 at 07:23:04PM +0200, Marco Molteni wrote:
> 
> 1. fatti mandare una copia esatta di un messaggio che non passa,
>    ed invialo da uno dei tuoi client personali che normalmente
>    funzionano. Questo test (con bassissime probabilita' di riuscita)
>    e' per verificare se c'e' magari uno strano pattern che fa trippare
>    un bug somewhere. Quello che non hai detto e' se qualunque attachment
>    fallisce o solo alcuni.
Falisce per qualsiasi mesg con allegato, indistintamente. C'Ŕ un % di
mesg molto bassa che passa miracolosamente...

> 2. tcpdump/ethereal is your friend. Sniffa il traffico su due lati:
>    di fronte e di dietro al bridge, chiedendo magari a qualcuno di
>    inviare via libero uno dei messaggi che non passano. Verifica
>    se ci sono comportamenti diversi nei 2 trace.
ci prover˛...

> 
> inoltre guardando i log, sembra che ci sia un timeout da
> qualche parte, passano dei minuti solo per la sequenza
> mail from rcpt to
Minuti? io ho fatto un tail -f del file dicoda che viene creato (nellav
/var/spool/postfix/etx/etc sulla macchina postfix) e vedo che l'header
del msg c' tutto, e PIAN PIANO ogni tanto arriva un flush
dell'attachment! Poi ad un punto la connessione andrÓ in timeout e uno
dei due endpoint la fa cadere!
> 
> Apr 21 19:50:38 host5 postfix/smtpd[2715]: 4A024B5842C: client=smtp0.libero.it[193.70.192.33]
> Apr 21 19:50:43 host5 postfix/cleanup[2716]: 4A024B5842C: message-id=<IFB4OT$D29CE09D322B40E5DE2914463078DF23 a libero.it>
> Apr 21 19:53:46 host5 postfix/smtpd[2640]: lost connection after DATA from smtp0.libero.it[193.70.192.33]
> Apr 21 19:53:46 host5 postfix/smtpd[2640]: disconnect from smtp0.libero.it[193.70.192.33]
> 
Ciao

Matteo



Maggiori informazioni sulla lista esperti