resume da suspend to ram

Enrico M. enricom a teppisti.it
Dom 28 Ott 2007 17:32:21 CET


Alle domenica 28 ottobre 2007, E.Richiardone ha scritto:
> Ciao
>
> On Sun, 28 Oct 2007 14:59:40 +0100, Enrico M. wrote:
>
> EM: Ho problemi a riemergere dal suspend to ram.
> EM: I problemi si verificano soltanto con X.
> EM: Se uso il notebook senza grafica, sospende e riemerge senza difficoltà.
> EM: Se però, dopo essere riemerso vado ad avviare X, la tastiera sembra non
> EM: funzionare e sono costretto a spegnere usando la gestione acpi del
> pulsante EM: on/off, quindi senza traumi.
> EM: Se vado in sospensione con X avviato, riemerge, ma scompaiono tastiera
> e mouse EM: e quindi non mi resta che spegnere come sopra.
> EM: La macchina è un thinkpad T30 P4 1600.
> EM: Ho spulciato nei logs, ma non viene registrato nulla degno di nota.
> EM: In /var/log/Xorg.0.log, alla ultime righe si legge "[RESUME] attempting
> to EM: re-init radeon hardware" seguito da agp mode 0x...........
> EM: Non so che pesci pigliare
>
> Ho un Thinkpad T40p con il tuo stesso problema, forse.
> Il guaio si trova nel driver DRI radeon che incarta Xorg al resume; ho
> risolto compilando drm e radeondrm come moduli, e caricandoli all'avvio in
> /boot/loader.conf
Purtroppo non funge.
Al resume si intoppa sempre allo stesso modo. 
Accedendo via ssh da altra macchina, ho dato un top ed ho scoperto che Xorg 
manda la cpu al 97-98% di carico.
Sicuramente gli si intoppa qualcosa, ma non riesco a capire cosa.
Enrico


Maggiori informazioni sulla lista esperti