installworld monco

Riccardo Torrini riccardo a torrini.org
Dom 6 Giu 2010 11:27:34 CEST


Tra ieri e oggi ho ricompilato e aggiornato un server 8.0
(fermo dal 28 febbraio) e secondo me ha fallito una parte
dell'installazione.  Questa lib non e` aggiornata:

# ls -log /libexec/
total 424
-r-xr-xr-x  1 root  wheel  schg 220020 Feb 28 14:18 ld-elf.so.1
-r-xr-xr-x  1 root  wheel  -    188096 Feb 28 09:14 ld-elf.so.1.old

# ls -log /usr/libexec/ld-elf*
lrwxr-xr-x  1 root  wheel  - 20 Jun  6 10:20 \
	/usr/libexec/ld-elf.so.1 -> /libexec/ld-elf.so.1

Tutti gli altri in /*bin, /usr/*bin e /usr/lib* sembrano
a posto.  Il problema credo sia qui (estratto del log di
installazione):

===> libexec/rtld-elf (install)
chflags noschg /usr/libexec/ld-elf.so.1
install -s -o root -g wheel -m 555  -C -b -fschg -S ld-elf.so.1 /libexec
install -o root -g wheel -m 444 rtld.1.gz  /usr/share/man/man1
/usr/share/man/man1/ld-elf.so.1.1.gz -> /usr/share/man/man1/rtld.1.gz
/usr/share/man/man1/ld.so.1.gz -> /usr/share/man/man1/rtld.1.gz
/usr/libexec/ld-elf.so.1 -> /libexec/ld-elf.so.1

Fa "chflags noschg" ad un soft-link e cerca di installare
sopra quello protetto.  Era noto?  Faccio un PR?


-- 
Riccardo. ( http://www.GUFI.org/~vic/ )


Maggiori informazioni sulla lista Esperti