apcupsd e smartups via usb

Toni bsd_ml a tiveron.net
Gio 2 Giu 2011 15:39:31 CEST


At 10:40 02-06-11, you wrote:
>Ciao,
>
>ho appena finito l'aggiornamento 6.4->8.2 e mi 
>e' rimasto un problema con lo smartups connesso via usb.
>apcupsd invia ogni minuto una mail 
>"Communications with UPS restored", ma ho notato che col demone stoppato
>ho comunque msg di sistema.
>
>La motherboard e' una miniitx intel d510mo.
>
>Qualche idea? (a parte staccare il cavo :)
>
>Grazie.
>
>$ uname -a
>FreeBSD sun.objectlab.org 8.2-RELEASE FreeBSD 
>8.2-RELEASE #0: Fri Feb 18 02:24:46 UTC 
>2011     root a almeida.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386
>
>$ usbconfig
>ugen0.1: <UHCI root HUB Intel> at usbus0, cfg=0 
>md=HOST spd=FULL (12Mbps) pwr=SAVE
>ugen1.1: <UHCI root HUB Intel> at usbus1, cfg=0 
>md=HOST spd=FULL (12Mbps) pwr=SAVE
>ugen2.1: <UHCI root HUB Intel> at usbus2, cfg=0 
>md=HOST spd=FULL (12Mbps) pwr=SAVE
>ugen3.1: <UHCI root HUB Intel> at usbus3, cfg=0 
>md=HOST spd=FULL (12Mbps) pwr=SAVE
>ugen4.1: <EHCI root HUB Intel> at usbus4, cfg=0 
>md=HOST spd=HIGH (480Mbps) pwr=SAVE
>ugen0.2: <Smart-UPS 1500 FW:601.3.I USB FW:1.3 
>American Power Conversion> at usbus0, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON
>
>
>Messaggi di disconnessione ripetuti in /var/log/messages:
>
>Jun  2 09:14:17 sun kernel: ugen0.2: <American 
>Power Conversion> at usbus0 (disconnected)
>Jun  2 09:14:18 sun kernel: ugen0.2: <American Power Conversion> at usbus0
>Jun  2 09:14:18 sun root: Unknown USB device: 
>vendor 0x051d product 0x0002 bus uhub0
>Jun  2 09:20:25 sun kernel: ugen0.2: <American 
>Power Conversion> at usbus0 (disconnected)
>Jun  2 09:20:26 sun kernel: ugen0.2: <American Power Conversion> at usbus0
>Jun  2 09:20:27 sun root: Unknown USB device: 
>vendor 0x051d product 0x0002 bus uhub0
>
>--
>Ciao,
>Mirko    http://www.lynapp.com
Avevo lo stesso problema con uno smart 700. 
Aggiornato il firmware dello stesso il problema si Ŕ risolto.
Avevo trovato anche come workaround che l'uso di 
un hub usb risolveva il problema.
Nel mio caso il problema era dovuto alla velocitÓ 
di negozazione della porta: il pc voleva usb2 ed 
il device arriva al massimo a 1.1




Maggiori informazioni sulla lista Esperti