Controller Perc6/i difettoso?

Davide D'Amico davide.damico a gmail.com
Sab 3 Mar 2012 09:46:06 CET


Ciao a tutti,
su due server DELL R410 identici (in conf master/slave) sullo slave
(fortuna, eh) ho questi errori in user.log:

mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 1874 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 1904 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 1934 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 1964 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 1994 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 2024 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 2054 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 2084 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 2114 SECONDS
mfi0: COMMAND 0xffffff80009aa7f8 TIMEOUT AFTER 2144 SECONDS

Inutile dire che durante questi timeout il server smette di rispondere
e nagios si arrabbia moltissimo.

Il controller in questione  un Perc6/i:
# mfiutil show adapter
mfi0 Adapter:
    Product Name: PERC 6/i Adapter
   Serial Number: 1122334455667788
        Firmware: 6.3.0-0001
     RAID Levels: JBOD, RAID0, RAID1, RAID5, RAID6, RAID10, RAID50
  Battery Backup: present
           NVRAM: 32K
  Onboard Memory: 256M
  Minimum Stripe: 8K
  Maximum Stripe: 1M
#

Il firmware  aggiornato a ${ULTIMARELEASE}-1:
# mfiutil show firmware
mfi0 Firmware Package Version: 6.3.0-0001
mfi0 Firmware Images:
Name  Version            Date         Time      Status
APP   1.22.12-0952       Jul 27 2010  16:44:00  active
BIOS  2.04.00                                   active
BCON  1.1-46-e_15-Rel    Mar  2 2008  14:06:08  active
CTLR  1.02-015B          Jan 27 2009  12:02:58  active
PCLI  01.00-023:#%00006  Nov 25 2008  17:21:50  active
BTBL  1.00.00.01-0011    Nov 27 2007  18:29:20  active
#

E il tipo di raid  un RAID1:

# mfiutil show drives
mfi0 Physical Drives:
(  279G) ONLINE <SEAGATE ST3300657SS ES64 serial=3SJ2YR74> SAS
enclosure 1, slot 0
(  279G) ONLINE <SEAGATE ST3300657SS ES64 serial=3SJ301ZH> SAS
enclosure 1, slot 1
# mfiutil show volumes
mfi0 Volumes:
  Id     Size    Level   Stripe  State   Cache   Name
 mfid0 (  279G) RAID-1      64K OPTIMAL Enabled  <BASE>
#

Tra l'altro il disco non  minimamente utilizzato, trattandosi di nodo slave.

Vi  mai successo? Potrebbe trattarsi di controller difettoso?
Abilitando/disabilitando la cache si ottengono risultati migliori?

Grazie,
-- 
d.


Maggiori informazioni sulla lista Esperti