Generate a powerpc image on an x86

Dario Freni saturnero at freesbie.org
Thu Jun 8 13:52:47 CEST 2006


Henri-Pierre Charles (hpcharles at gmail.com) wrote:
> Hello, for the record, this is my first trial to generate a powerpc
> image on an x86 hardware.
> 
> I have add ARCH=powerpc in the freesbie.conf, remove the "machine
> powerpc" line in the conf/powerpc/FREESBIE, it seem useless. I also
> have replaced the iso.sh file by powerpc/iso.sh.

You don't have to replace iso.sh with powerpc/iso.sh. The toolkit is
aware that if a file exists for a target under ${ARCH}/${TARGET}.sh,
it has to be used instead of ${TARGET}.sh

The custom/ dir, also, has precedence over all the rest, so if you
have e.g. custom/${TARGET}.sh this script is invoked instead of the
others. The custom/ directory path is freesbie2/scripts/custom by
default and it can be overriden with the SCRIPT_OVERRIDE variable.

> Everything is ok during the build process (except for the package
> installation of course)
> 
> Next step is to test it, unfortunately, on only have a G5, which is
> not supported actually.
> I have tried to boot but the cd is not recognized. I have tried with
> qemu with this command lire :
> 
> qemu-system-ppc -boot d -cdrom /usr/tmp/Isos/FBIEUvsqPpc-0.3.iso
> 
> but it give error : the cdrom don't seem bootable on ppc platform.
> 
> Any hints ?

Neither FreeBSD-6.0 powerpc install cd works under qemu-ppc. You may
want to try pearpc, but me and Paolo have tried using it without
success, as the bundled openfirmware implementation seems not to have
enough room to store loader+kernel at boot.
 
> PJ : the ouput of the build process and the error message from qemu
> 
> #### Building kernel for powerpc architecture ####
> >>>Kernel build for FREESBIEpowerpc started on Thu Jun  8 10:19:10 CEST 2006
> >>>stage 1: configuring the kernel
> >>>stage 2.1: cleaning up the object tree
> >>>stage 2.2: rebuilding the object tree
> >>>stage 2.3: build tools
> >>>stage 3.1: making dependencies
> >>>stage 3.2: building everything
> >>>Kernel build for FREESBIEpowerpc completed on Thu Jun  8 10:34:37 CEST 
> >>>2006
> #### Installing world for powerpc architecture ####
> >>>Making hierarchy
> >>>Installing everything
> #### Installing kernel for powerpc architecture ####
> >>>Installing kernel
> ----------------------------------------------------------
> You can install packages only if your machine architecture
> is the same of the target architecture.
> ----------------------------------------------------------
> Skipping package installation.
> #### Running plugins ####
> -> customroot
> Copying content of extra/customroot directory to the livefs
> -> rootmfs
> Adding init script for /root mfs
> Saving mtree structure for /root
> -> etcmfs
> Adding init script for /etc mfs
> Saving mtree structure for /etc
> -> xconfig
> -> sound
> -> adduser
> chroot: pw: Exec format error
> Adding init script for /home mfs
> Saving mtree structure for /home/
> #### Cloning /usr/home/hpc/freesbie-fs-ppc to 
> /usr/home/hpc/freesbie-clone-ppc #
> ###
> Compressing /usr/home/hpc/freesbie-clone-ppc/uzip/usr.ufs... 69.4395% saved
> #### Building bootable ISO image for powerpc ####
> Saving mtree structure...
> Running mkisofs...
> ISO created:
> -rw-r--r--  1 root  hpc   478M Jun  8 10:50 
> /usr/home/hpc/FBIEUvsqPpc-0.3.iso
> manet# scp /usr/home/hpc/FBIEUvsqPpc-0.3.iso hpc at vlaminck:/usr/tmp/Isos
> Password:
> FBIEUvsqPpc-0.3.iso                           100%  478MB  10.4MB/s   00:46

Just to be sure you have created the iso image using the correct
script, please paste the output of "file FBIEUvsqPpc-0.3.iso", or
launch the iso target by setting the FREESBIE_DEBUG variable to
something.

Bye,
D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://mailman.gufi.org/pipermail/freesbie/attachments/20060608/de46f568/attachment.bin


More information about the FreeSBIE mailing list